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JulyJulyJulyJuly    2007 2007 2007 2007 ----    Letter from the EditorLetter from the EditorLetter from the EditorLetter from the Editor    
Welcome to the fifth edition of the BetterSolutions.com newsletter. First we must apologise for the late 

publishing of this newsletter and also for the delay in replying to user’s questions. This month we have had an 

explosion of consultancy work and have also been working on several long term projects. Despite these other 

commitments we have still been able to add a lot more Word and PowerPoint Knowledge Base articles to the 

website. The function links for BIN2HEX and BIN2OCT have been corrected and we have also made a few 

subtle changes to some of the other worksheet function pages. 

http://http://http://http://office.microsoft.comoffice.microsoft.comoffice.microsoft.comoffice.microsoft.com    
You will find lots of useful information 

including plenty of templates and how-to 

articles on the Microsoft Online website. This 

website contains a huge amount of information 

not to mention the enormous collection of 

professionally designed templates that you can 

download and modify. The new and improved 

layout and navigation makes it a lot easier to 

find information and all this content is available 

from within your Office applications. Pressing 

F1 in any of the Office applications will display 

the Help task pane or Help window. 

 

Developers UpdateDevelopers UpdateDevelopers UpdateDevelopers Update    
The ASP.NET 2.0 enhancements are going well and we have almost finished creating a members login page. 

This has taken slightly longer than we thought because we want to make sure this interface is scalable and can 

be easily integrated with Microsoft SharePoint at a later date. Back in April we mentioned that we are working 

on some utility add-ins and we still are. The initial testing has been completed but we did identify a few areas 

that needed improving. We are very keen to try and get this right before we distribute any software on a wide 

scale. All our utility add-ins allow personal settings to be saved and these obviously need to be reloaded when 

a new version is installed. We are also enhancing the error handling as well as trying to write some automated 

scripts to ensure that new versions are backwards compatible. 

suppsuppsuppsupport@bettersolutions.comort@bettersolutions.comort@bettersolutions.comort@bettersolutions.com    
This email address is the one you should use when you have any problems or questions with Microsoft Office 

and you want some FREE help and advice. Sending us your questions will not only mean that you get a reply 

immediately but will also allow us to publish the answers in the next issue which will help other people as 

well. We spend a lot of time checking and testing the information to ensure that it is accurate but if you do 

spot any mistakes or anything that is wrong then please tell us. We are always looking for ways to improve our 

products and services and always welcome constructive criticism. If you have any comments or suggestions 

regarding this newsletter and the content contained inside it please tell us. 
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News and Related INews and Related INews and Related INews and Related Informationnformationnformationnformation    

FactFactFactFactssss of the month of the month of the month of the month    
This month our useful facts are relating to Excel shortcut keys. 

(Ctrl + 1)Ctrl + 1)Ctrl + 1)Ctrl + 1) displays the (Format > Cells)(Number tab) dialog box. 

(Alt + Tab)(Alt + Tab)(Alt + Tab)(Alt + Tab) lets you switch between the different applications that you currently have open. 

(Ct(Ct(Ct(Ctrl + Tab) rl + Tab) rl + Tab) rl + Tab) or (Ctrl + F6)(Ctrl + F6)(Ctrl + F6)(Ctrl + F6) lets you switch to the next workbook (when multiple workbooks are open). 

(Ctrl + Shift + Tab)(Ctrl + Shift + Tab)(Ctrl + Shift + Tab)(Ctrl + Shift + Tab) or (Ctrl + Shift + F6)(Ctrl + Shift + F6)(Ctrl + Shift + F6)(Ctrl + Shift + F6) lets you switch to the previous workbook (when multiple workbooks 

are open). 

Microsoft Office 2007 VersionsMicrosoft Office 2007 VersionsMicrosoft Office 2007 VersionsMicrosoft Office 2007 Versions    
In previous versions of Microsoft Office it was a lot easier to decide which version was the most suitable for 

your particular job. In Office 2003 you had a choice between 4 different versions: student, standard, small 

business or professional. All four versions included the main four applications (Excel, Word, PowerPoint and 

Outlook). The small business version included Publisher and the Professional version included Access. In 

Office 2007 however it is a lot harder to decide as there are now 8 different versions to choose from. For most 

users the Standard version is more than adequate. If you are a VBA developer and you use Access then the 

Professional version might be a better choice. 

 

This is a summary of the different versions (or suites) that are available for Office 2007: 

Basic Basic Basic Basic – This includes Excel, Word and Outlook. 

StandardStandardStandardStandard – This includes Excel, Word, PowerPoint and Outlook. 

Home and Student Home and Student Home and Student Home and Student – This includes Excel, Word, PowerPoint and OneNote. 

Small Business Small Business Small Business Small Business – This includes Excel, Word, PowerPoint, Outlook (with Business Contact Manager), Publisher 

and Accounting Express. 

ProfessionalProfessionalProfessionalProfessional – This includes Excel, Word, PowerPoint, Outlook (with Business Contact Manager), Publisher 

and Access. 

Professional Plus Professional Plus Professional Plus Professional Plus – This includes Excel, Word, PowerPoint, Outlook, Publisher, Access, InfoPath, 

Communicator, Integrated Enterprise Content Management, Integrated Electronic Forms and Information 

Rights Management. 

UltimateUltimateUltimateUltimate – This includes Excel, Word, PowerPoint, Outlook (with Business Contact Manager), Publisher, 

Access, InfoPath, Groove, OneNote, Enterprise Content Management, Integrated Electronic Forms and 

Information Rights Management. 

EnterpriseEnterpriseEnterpriseEnterprise – This includes Excel, Word, PowerPoint, Outlook, Publisher, Access, InfoPath, Groove, OneNote, 

Communicator, Enterprise Content Management, Integrated Electronic Forms and Information Rights 

Management. 

DisclaimerDisclaimerDisclaimerDisclaimer    
Better Solutions Limited is in no way associated with Microsoft Corporation. All the content in this newsletter 

and on the website is provided “as is” with absolutely no warranties. We strongly recommend that you back up 

all your data first before installing any updates or third party software. In no event shall Better Solutions 

Limited be liable for any special, indirect or consequential damages whatsoever resulting from loss of use, data 

or profits, whether in an action of contract, negligence or other action arising out of or in connection with any 

information published in this newsletter or on our website. 
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Your Questions and ProblemsYour Questions and ProblemsYour Questions and ProblemsYour Questions and Problems    
Excel Excel Excel Excel –––– How can I display tic How can I display tic How can I display tic How can I display ticks (or check marks) in a worksheet?ks (or check marks) in a worksheet?ks (or check marks) in a worksheet?ks (or check marks) in a worksheet?    
The default Excel font is Times New Roman but there are actually lots of other built-in fonts which you can 

also use. Displaying characters other than letters can be easily achieved by formatting the cell with a different 

font. You can use the (Insert > Symbol) dialog box to see the full range of characters. 

Excel Excel Excel Excel –––– How can I add a button to a worksheet? How can I add a button to a worksheet? How can I add a button to a worksheet? How can I add a button to a worksheet?    
There are in fact two ways you can do this and which method you use will depend on how the button is to be 

used. The most common way is to use the Forms toolbar and drag a button onto a worksheet. The Forms 

toolbar is only available for backwards compatibility despite a lot of the functionality not being available in the 

more recent Control Toolbox toolbar. To add a button to a worksheet display the Forms toolbar and press the 

Button command so it is pressed. This is the fourth command on this toolbar. Use the mouse to drag a 

rectangle over the worksheet where you would like the button to be. This will create a button and will also 

automatically display the “Assign Macro” dialog box. This allows you to select the macro you want to run 

when this button is pressed. 

Excel Excel Excel Excel –––– How can you quickly convert a column letter to a column number? How can you quickly convert a column letter to a column number? How can you quickly convert a column letter to a column number? How can you quickly convert a column letter to a column number?    
Often when you are working in a workbook it is useful to cross reference the column letters with their actual 

numbers. You can easily toggle the display of column numbers or column letters by selecting (Tools > 

Options)(General tab, “R1C1 reference style”). 

Excel Excel Excel Excel –––– How can I display a time as a  How can I display a time as a  How can I display a time as a  How can I display a time as a sssspecific pecific pecific pecific number of hours?number of hours?number of hours?number of hours?    
Dates and Times in Excel are represented as numbers (called serial numbers). The integer part of a serial 

number represents the number of days and the decimal part of a serial number represents the number of hours 

and minutes. The default starting date in Excel is 1st January 1900. Therefore a date serial number of 100.25 

actually represent Monday 9th April 1900, 

06:00am. To split a time into its exact number of 

hours you need to multiply its decimal part by 

24 and round down to the nearest integer. To 

split a time into its exact number of minutes you 

must first remove the number of hours and then 

you need to multiply its decimal part by 60 and 

round down to the nearest integer. To split a 

time into its exact number of seconds you must 

first remove the hours and minutes and then you 

need to multiply its decimal part by 60 and 

round up. 

 

Word Word Word Word –––– Why is this template loading when I open Word? Why is this template loading when I open Word? Why is this template loading when I open Word? Why is this template loading when I open Word?    
Any templates (or files) that are saved in your Word start-up directory will open automatically when Word 

opens. The most common way to find any dubious templates is to search for all the files that contain (*.dot). 

This approach however will not identify any shortcuts that might have been created. It is possible to save a 

shortcut to a template in the start-up folder rather than saving the actual template. Shortcuts will not be found 

if you search for the (*.dot) file extension. The only way to be absolutely sure there is nothing in your start-up 

folders is to browse to the actual folders using Windows Explorer. Word 2003 has two start-up folders: 

C:C:C:C:\\\\Documents and SettingsDocuments and SettingsDocuments and SettingsDocuments and Settings\\\\"user name""user name""user name""user name"\\\\Application DataApplication DataApplication DataApplication Data\\\\MicrosoftMicrosoftMicrosoftMicrosoft\\\\WordWordWordWord\\\\STARTUPSTARTUPSTARTUPSTARTUP\\\\    

C:C:C:C:\\\\Program FilesProgram FilesProgram FilesProgram Files\\\\Microsoft OfficeMicrosoft OfficeMicrosoft OfficeMicrosoft Office\\\\OFFICE11OFFICE11OFFICE11OFFICE11\\\\STARTUPSTARTUPSTARTUPSTARTUP\\\\
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Function Function Function Function ––––    TEXTTEXTTEXTTEXT    
This is an extremely useful function that can be used to format numbers. When you use the (Format > Cells) 

dialog box you are only changing the format of the number, not the actual value. When you use the TEXT 

function to format a number you are changingare changingare changingare changing the actual value. The first argument can be anything that 

evaluates to a numerical value (text string, cell reference or formula). The second argument is the format you 

want the text string to be and must be enclosed in speech marks. This function always returns its value as a 

text string. You can easily see this because the 

value in cell “B2” is right aligned whereas the 

value returned from the formula in cell “B3” is 

left aligned. 

 

This function is useful when you need to create 

a text string that contains numbers or dates 

formatted in a particular way. Let’s imagine that 

you wanted to display the following text string 

Today’s date is: Today’s date is: Today’s date is: Today’s date is: SaturdaySaturdaySaturdaySaturday 25  25  25  25 AugustAugustAugustAugust 2007 2007 2007 2007 in cell 

“B5”. This can be achieved by concatenating a 

text string with the text string returned from 

the TEXT function. In this example we are 

passing in the function TODAY which returns 

the serial number representing today’s date. 

Cell Shortcut MenuCell Shortcut MenuCell Shortcut MenuCell Shortcut Menu    
A Cell shortcut menu is displayed when you select a cell (or range) and press the opposite button on your 

mouse (for those us of that are right-handed, this is the right mouse button). Exactly what commands are 

displayed on this shortcut menu will depend on the context of 

what you are doing and the view that is currently being 

displayed. For example if you create a blank workbook and 

right click on a blank cell the default shortcut menu will be 

displayed. This shortcut menu includes the following two 

commands: 

The InsertInsertInsertInsert    command displays the Insert dialog box. 

The DeleteDeleteDeleteDelete command displays the Delete dialog box. 

 

However if the active worksheet contains a filtered table then 

the Cell shortcut menu will display slightly different 

commands. For example we have created a simple table of 

data “B2:D10”, added an AutoFilter and filtered the data by 

department. Selecting any cell on this worksheet and pressing 

the right mouse button will display a slightly different 

shortcut menu. This shortcut menu replaces the Insert and 

Delete commands with the following two commands: 

The Insert RowInsert RowInsert RowInsert Row command will insert the same number of 

rows that are currently selected above the current selection. 

The Delete RowDelete RowDelete RowDelete Row command will delete the rows in the current 

selection (with a prompt first). 
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Function Function Function Function ---- COUNTIF COUNTIF COUNTIF COUNTIF 

This function returns the number of cells in a range that satisfies a condition. For example you could use this 

function to return the number of cells that contain a particular value. For example in the table below we can 

use the COUNTIF function to return the number of cells in 

the range “B2:C12” that contain the word “Russell” by using 

the following function: 

=COUNTIF(B2:C12,"Russell"=COUNTIF(B2:C12,"Russell"=COUNTIF(B2:C12,"Russell"=COUNTIF(B2:C12,"Russell")))) = 5 = 5 = 5 = 5    

 

Notice that this function can be used with any size range, it 

does not have to be a single row or a single column. The 

following function will return the number of cells in the 

range “B2:C12” that contain text: 

=COUNTIF(B2:C12,"*") = 17=COUNTIF(B2:C12,"*") = 17=COUNTIF(B2:C12,"*") = 17=COUNTIF(B2:C12,"*") = 17    

 

The cells that are excluded from the count are “B7”, “B10”, “C6”, “C9” and “C11”. These are the cells that 

contain numbers and those that are empty. Notice that the null string in cell “B3” is included. The following 

function will return the number of cells in the range “B2:C12” that do not contain any text: 

=COUNTIF(B2:C12,"<>"&”*”)=COUNTIF(B2:C12,"<>"&”*”)=COUNTIF(B2:C12,"<>"&”*”)=COUNTIF(B2:C12,"<>"&”*”) = 5 = 5 = 5 = 5    

Handling ZerosHandling ZerosHandling ZerosHandling Zeros, , , , BlanksBlanksBlanksBlanks and the Null String and the Null String and the Null String and the Null String    
A Zero is a cell that contains the value 0 either as a constant or returned from another formula. A Blank is a 

cell that is completely empty and has not been populated. The Null String is a cell that contains an empty 

string, often returned from another formula. The table and formulas below illustrate that working with zeros, 

blanks and null strings can often lead to unexpected results. The formula in cell “E2” is counting all the cells in 

the range “B2:B11” that contain a zero constant. As you would expect the number returned is 1. 

 

The formula in cell “E3” is counting all 

the cells in the same range that contain 

an empty cell. You might have thought 

that this formula would return the 

number 9 but in fact this returns the 

number 1. This function matches blank 

cells with zero cells. 

 

The formula in cell “E4” is counting all 

the cells in the same range that contain a 

null string. Again this leads to some 

unexpected results because this returns the number 9. This function matches null strings with blank cells. This 

is definitely a bit confusing. Please send us your thoughts and we will publish these in the next issue. 

 

This particular screen shot has been taken from Excel 2007 to give all our readers a preview of the new Excel 

2007 interface. The softer colours and improved graphics all help to make the application more user friendly. 

Eventually all the newsletter screen shots will be taken from Office 2007. 
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Excel 2007 Excel 2007 Excel 2007 Excel 2007 –––– Page Layout Tab Page Layout Tab Page Layout Tab Page Layout Tab    
One of the new features in Excel 2007 is the new Page Layout view and to accompany this view there is a 

dedicated tab. Another significant improvement in this version is the introduction of Themes. Being able to 

apply a consistent look and feel to all your workbooks, documents and presentations using themes is a great 

feature. Themes are pre-defined colours, font styles and effects that are integrated across Excel, Word and 

PowerPoint. A theme consists of 12 colours, a heading font, a body font and an effect. In Excel 2007 the colour 

palette is no longer a random collection of 52 colours but is 

now linked implicitly to colours defined in a theme. 

However you want your files to look you can define a 

theme accordingly. Excel 2007 comes with 21 built-in 

colour schemes, 23 built-in font styles and 20 built-in 

effects. This gives you a choice of over 9,000 different 

options plus you can easily create your own. Themes can 

also be saved to external files meaning they can be easily 

shared, modified or distributed. A lot of the commands found on this tab are also available in Word and 

PowerPoint and have exactly the same functionality. 

 

ThemesThemesThemesThemes    
This group is consistent across all three applications and provides you with all the necessary theme related 

commands. The large themes drop-down list provides a list of all the themes that are currently available. The 

Colors drop-down list displays a list of all the built-in colour schemes plus any custom colour schemes that 

might also be available. The Color drop-down list doesn’t indicate which colour scheme is currently selected 

and when you display the drop-down list the active colour scheme is not very prominent. The only alternative 

that we found to identify the active colour scheme was to hover over the drop-down list and wait several 

seconds for the descriptive screen tip. 

 

The Fonts drop-down list actually displays a list of font styles, not fonts. Every font style 

has a pre-defined heading font and a pre-defined body font. For example the first built-in 

font style is called Office. This uses the Cambria font as its heading and the Calibri font 

for its body text. The font drop-down list doesn’t indicate which font style is currently 

selected. The only way to identify which font style is being used is to hover or display 

the whole drop-down list. The font drop-down list seems to take up a large part of the screen which surely 

defeats the point of having the Live Preview feature. 

 

Page SetupPage SetupPage SetupPage Setup    
The Margins drop-down list displays three built-in 

margin settings. It doesn’t look like you can define 

and save your own settings but it is a lot better 

than it was. The Orientation drop-down list lets 

you quickly switch the printing orientation 

between portrait and landscape. The Size drop-down list lets you quickly select the paper size that you want to 

use when you print and the Print Area drop-down list is exactly the same as the earlier (File > Print Area) 

extension menu. The Breaks drop-down list contains the three commands that appear on the Cell shortcut 

menu when in Page Layout view. This means the “second” Cell shortcut menu is no longer used. The 

Background button displays the Sheet Background dialog box which is the same as the earlier (Format > Sheet 

> Background) command. The Print Titles button displays the Sheet tab of the Page Setup dialog box. You can 
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quickly display the (File > Page Setup)(Page tab) by clicking in the bottom corner of this group. This button is 

also known as a Dialog Launcher. 

 

Scale to FitScale to FitScale to FitScale to Fit    
This group displays three combo boxes that control some of the settings from the 

earlier (File > Page Setup) dialog box. The Width combo box controls the number of 

pages you want to print to horizontally. The Height combo box controls the number 

of pages you want to print to vertically. It is probably best to switch to the Page 

Layout view before you change any of these options otherwise it is very difficult to 

see your changes. You can quickly display the (File > Page Setup)(Page tab) by clicking in the bottom corner of 

this command set. 

 

Sheet OptionsSheet OptionsSheet OptionsSheet Options    
These four checkboxes refer to two of the checkboxes on the (Tools > Options)(View 

tab) and two of the checkboxes on the (File > Page Setup)(Sheet tab). The term 

“Headings” refers to the row and column headings. Having all these checkboxes together 

in a single group is a lot more intuitive. The default setting (as displayed in the screen 

shot) is to display both the gridlines and the row and column headings on the screen but 

not to print them. You can quickly display the (File > Page Setup)(Sheet tab) by clicking in the bottom corner 

of this command set. 

 

ArrangeArrangeArrangeArrange    
The Bring to Front and Send to Back look the same as all the other commands in this group although they are 

actually buttons with drop-down lists instead of just drop-down lists. The large button above the drop-down 

list allows you to quickly bring objects to the front or send them to the back with a single click. You only need 

to use the drop-down lists when you want to bring an object 

forward one layer or send an object back one layer. I wish 

there was some way of distinguishing other than hovering over 

with your mouse but having said that these commands are 

consistent across Excel, Word and PowerPoint making it much 

easier to remember. The Selection Pane is a new feature which can be used to display the Selection and 

Visibility task pane. This displays a list of all the objects on the active worksheet and their corresponding shape 

names. This will prove to be very useful when you need to manage a lot of objects on the same worksheet and 

also allows you to quickly show and hide specific objects. The Align drop-down list displays the commands 

from the earlier Align or Distribute toolbar. The Group drop-down list displays the familiar Group, Ungroup 

and Regroup commands and the Rotate drop-down list displays the commands from the earlier Rotate or Flip 

toolbar. 

 

Page Layout Tab SummaryPage Layout Tab SummaryPage Layout Tab SummaryPage Layout Tab Summary    
This tab definitely gives you quick access to everything relating to page layout and printing. The Themes and 

the Page Setup groups are almost identical across Excel, Word and PowerPoint which definitely makes the 

transition between applications a lot easier. The new Page Layout view is a great addition and makes working 

with headers and footer significantly easier. The Selection Pane is a great addition and on the whole all the 

commands on this tab are intuitively organised. If I had to be critical the only question that I have is why is 

there no way to switch to the Page Layout view from the Page Layout tab? 


