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JuneJuneJuneJune 2007  2007  2007  2007 ----    Letter from the EditorLetter from the EditorLetter from the EditorLetter from the Editor    
Welcome to the fourth edition of the BetterSolutions.com newsletter. This month we have added a lot more 

Knowledge Base articles to the Excel sections and have also made significant improvements to the Word, 

Track Changes section. Two additional pages have been added to the Excel, Formulas section as well as a 

dedicated page on how to compare two Excel ranges. If you think the content in this newsletter is perhaps a 

bit too advanced then you will be pleased to here that we will be discussing more of the essential topics in 

future issues. In this issue we are discussing cell references and the difference between absolute and relative 

references. The aim of the newsletter is really to supplement the website rather than repeat or duplicate 

content that can be found on the website. Your comments and feedback are very much appreciated. 

Developers Developers Developers Developers UpdateUpdateUpdateUpdate    
We are in the process of transferring parts of the website to ASP.NET 2.0 to make it more interactive. This is a 

slow process but we have almost completed the first phase which is to allow members to login and change 

their personal details. This will hopefully go live next month. We could just copy and paste functionality from 

other well known sources but in order to guarantee that this website is unique and provides our visitors and 

members with accurate and easy to find information we are insisting on writing all the code ourselves. Unlike 

other websites we are committed to using the latest Microsoft technology and are therefore using the 

Membership API with .NET 2.0 Login Controls. 

Knowledge Base ArticlesKnowledge Base ArticlesKnowledge Base ArticlesKnowledge Base Articles    
We have spent a lot of time identifying all the 

relevant knowledge base articles and collating all 

this information into a central database. A lot more 

of the Excel knowledge base articles have been 

identified this month and these have been added to 

the corresponding pages in the Excel section. It is 

now possible to quickly find all the relevant articles 

and known bugs relating to a specific topic. These 

articles are split into versions and will eventually 

indicate which articles contain VBA code. The 

developer community will definitely appreciate this 

information. We are hoping to upload the Word and 

PowerPoint articles in the next month or so. 

support@bettersolutions.comsupport@bettersolutions.comsupport@bettersolutions.comsupport@bettersolutions.com    
This email address is the one you should use when you have any problems or questions with Microsoft Office 

and you want some FREE help and advice. Sending us your questions will not only mean that you get a reply 

immediately but will also allow us to publish the answers in the next issue which will help other people as 

well. We spend a lot of time checking and testing the information to ensure that it is accurate but if you do 

spot any mistakes or anything that is wrong then please tell us. We are always looking for ways to improve our 

products and services and always welcome constructive criticism. If you have any comments or suggestions 

regarding this newsletter and the content contained inside it please tell us. 
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News and Related InformationNews and Related InformationNews and Related InformationNews and Related Information    

FactFactFactFactssss of the month of the month of the month of the month    
The facts this month are relating to how data is presented in Excel. The first is that numbers are only saved to 

15 significant figures. Any numbers entered with more than 15 significant figures are automatically truncated. 

The other fact is that the default font for new workbooks is Arial 10. You can change the default font used 

from the (Tools > Options)(Edit tab). You must close and re-open Excel for these changes to be saved. Your 

default font is also used to display the worksheet column and row labels. 

Office Compatibility PackOffice Compatibility PackOffice Compatibility PackOffice Compatibility Pack    
If you are using Office 2002 or Office 2003 this compatibility pack allows you to open, edit and save XML file 

formats in the earlier versions of Microsoft Office. This allows you to open and save workbooks, documents 

and presentations in the new Open XML file formats. You should make sure that you have all the high-

priority updates from the Microsoft Update website before installing this pack. Please refer to the following 

knowledge base article http://support.microsoft.com/kb/924074http://support.microsoft.com/kb/924074http://support.microsoft.com/kb/924074http://support.microsoft.com/kb/924074 for more details. 

Office Migration Planning Manager (OMPM)Office Migration Planning Manager (OMPM)Office Migration Planning Manager (OMPM)Office Migration Planning Manager (OMPM)    
The Office Migration Planning Manager is a group of tools designed to help administrators during the 

planning and testing phases of a Microsoft Office 2007 deployment. These tools enable you to examine the files 

in your environment and decide whether to archive them, convert them in bulk or to convert them manually. 

These tools are designed to help administrators to understand their environment and to effectively plan for a 

smooth rollout of Office 2007. There are lots of new and modified features in Office 2007 such as the new file 

formats and new setup architecture. Administrators will probably need to evaluate all the files in their 

environment, identify potential conversion issues, and spend time considering the specific changes to the 

Microsoft Office applications. This tool can be downloaded from the Microsoft website using the following 

link: http://www.microsoft.com/downloads/details.aspx?FamilyID=13580cd7http://www.microsoft.com/downloads/details.aspx?FamilyID=13580cd7http://www.microsoft.com/downloads/details.aspx?FamilyID=13580cd7http://www.microsoft.com/downloads/details.aspx?FamilyID=13580cd7----a8bca8bca8bca8bc----40ef40ef40ef40ef----8281828182818281----dd2c325a5a81dd2c325a5a81dd2c325a5a81dd2c325a5a81. 

Microsoft Support LifecycleMicrosoft Support LifecycleMicrosoft Support LifecycleMicrosoft Support Lifecycle    
This is a quick overview of the support lifecycle. For more details visit: http://support.microsoft.com/lifecyclehttp://support.microsoft.com/lifecyclehttp://support.microsoft.com/lifecyclehttp://support.microsoft.com/lifecycle. 

● 10 years support for business and developer products (e.g. Microsoft Office) 

● 5 years support for service packs (e.g. Windows XP SP1) 

● 3 years support for products released annually (e.g. Money, Encarta) 

● Online help is available for a minimum of 12 months after a product is no longer supported. 

When a new service pack is released Microsoft will continue to provide support for an earlier service pack for 

a minimum of 12 months. Support for the Windows XP Service Pack 1 ended in October 2006. If you don’t 

have Windows XP Service Pack 2 installed on your computer it can (and should) be downloaded free of charge 

from the Microsoft website. 

DisclaimerDisclaimerDisclaimerDisclaimer    
Better Solutions Limited is in no way associated with Microsoft Corporation. All the content in this newsletter 

and on the website is provided “as is” with absolutely no warranties. We strongly recommend that you back up 

all your data first before installing any updates or third party software. In no event shall Better Solutions 

Limited be liable for any special, indirect or consequential damages whatsoever resulting from loss of use, data 

or profits, whether in an action of contract, negligence or other action arising out of or in connection with any 

information published in this newsletter or on our website. 



June 2007 support@bettersolutions.com 

Copyright © Better solutions Limited. All Rights Reserved. Page 3 of 7 
No part of this publication can be published or reprinted without explicit written permission from Better Solutions Limited 

Your Questions and ProblemsYour Questions and ProblemsYour Questions and ProblemsYour Questions and Problems    
Excel Excel Excel Excel ---- How can I see more of my sheet tabs? How can I see more of my sheet tabs? How can I see more of my sheet tabs? How can I see more of my sheet tabs?    
If you are using long descriptive names for your tabs then you might find that not all of your tabs are visible at 

the same time. The most obvious suggestion is to keep your tab names as short as possible by trying to use 

abbreviations. You will also notice that at the bottom of Excel directly to the right of the tabs is a horizontal 

scroll bar. Between the scroll bar and the tabs is a horizontal block called the tab split box. This divides the 

tabs from the horizontal scroll bar. You can increase the area allocated for the worksheet tabs by positioning 

the cursor over the tab split box and dragging it with the right mouse button. 

 

Excel Excel Excel Excel ---- What is the quickest way to select a worksheet tab What is the quickest way to select a worksheet tab What is the quickest way to select a worksheet tab What is the quickest way to select a worksheet tab that is not visible that is not visible that is not visible that is not visible????    
The quickest way is to right click on any of the tab scrolling buttons. These buttons are immediately to the left 

of the worksheet tabs. Right clicking will display a shortcut menu that lists all the worksheets in the current 

workbook. You can use this shortcut menu to select the worksheet you want. If you have more than 15 

worksheets in the workbook you can select “More Sheets” to display the Activate dialog box. 

 

Excel Excel Excel Excel ----    Is there a way I can quickly select all the cells that contain errors?Is there a way I can quickly select all the cells that contain errors?Is there a way I can quickly select all the cells that contain errors?Is there a way I can quickly select all the cells that contain errors?    
1. Select (Edit > Go To) to display the Go To dialog box. 

2. Press the Special button in the bottom left corner to display the Go To Special dialog box. 

3. Choose the Formulas option and untick the Numbers, Text and Logicals checkboxes. 

4. Press OK to highlight all the cells on the active worksheet that contain errors. 
 

Excel Excel Excel Excel ----    Why does the height of my rows keep changing?Why does the height of my rows keep changing?Why does the height of my rows keep changing?Why does the height of my rows keep changing?    
The default row height in a new worksheet is fixed at 12.75 and can be manually adjusted. The reason the 

height of a row might be changing automatically is if some of the cells in that row have been formatted with 

“Wrap Text”. When a cell has been formatted with wrap text the row height is automatically adjusted 

depending on the amount of text in that particular cell. The wrap text option can be found on the (Format > 

Cells)(Alignment tab). Making a manual adjustment to the height of a row will lock the row height and 

prevent it from changing automatically. 

 

Excel Excel Excel Excel –––– How can I display two labels in the same cell? How can I display two labels in the same cell? How can I display two labels in the same cell? How can I display two labels in the same cell?    
The only way of achieving this result is to type both 

words into the cell and then use additional spaces 

before the first word to push it over the right hand side 

of the cell. Start by typing in “Years Months” into cell 

“B3”. Then select (Format > Cells)(Border tab) and add 

a diagonal line to this cell. Select (Format > 

Cells)(Alignment tab) and make sure the “Wrap Text” 

checkbox is selected. You can then manually insert 

extra spaces in front of the word Years so it appears on the right hand side. 

 

PowerPoint PowerPoint PowerPoint PowerPoint ––––    Why have my graphics bWhy have my graphics bWhy have my graphics bWhy have my graphics been replaced with red crosseeen replaced with red crosseeen replaced with red crosseeen replaced with red crosses?s?s?s?    
Graphics and pictures will be automatically replaced with red crosses when there is not enough memory to 

display the graphics. Do not save your presentation with red crosses as it may not be possible to recover the 

graphics afterwards. A workaround to this problem is to close the presentation without saving and close all 

your other applications to try and free up resources before re-opening the file. Please refer to the following 

knowledge base article http://support.microsoft.com/kb/291874http://support.microsoft.com/kb/291874http://support.microsoft.com/kb/291874http://support.microsoft.com/kb/291874 for more details. 
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Formulas and Cell ReferencingFormulas and Cell ReferencingFormulas and Cell ReferencingFormulas and Cell Referencing    
Instead of hard typing all the values used in a spreadsheet it is possible to link to other cells using formulas. 

This technique is known as cell referencing and allows a spreadsheet to become more dynamic. The simplest 

type of cell reference is one that refers to an individual cell on the same worksheet. Let’s consider that we have 

four numbers and we want to display the total. We don’t want to hard type the total in case any of the 

numbers change. Let’s create a worksheet that resembles the screen shot below. We will type the four 

numbers in column “C” and below that we will insert a formula 

that will use cell references to return the total. When you are 

entering a formula you can either use the formula bar or you 

can type directly in the cell. You can either type the cell 

references or you can use the mouse to select the cells you 

want to reference. 

Select cell “C7” and press “=”. Starting the contents of a cell 

with an equal sign tells Excel that you are about to insert a 

formula rather than just entering some numbers or text. Select 

cell “C2” and then press the plus sign (+) on the keyboard to enter the addition operator. You can then repeat 

this process for cells “C3”, “C4” and “C5”. Once you have entered the formula you can press Enter. The cell 

should display the number 55 which is the total of the four numbers. 

Types of Cell ReferencesTypes of Cell ReferencesTypes of Cell ReferencesTypes of Cell References    
There are two types of cell reference that you can use in your spreadsheets. The first type is called relative 

reference and should be used when you want your cell references to change relative to the cell containing the 

formula. The other type is called absolute reference and should be used when you want a formula to always 

refer to the same cell. The type of cell referencing used is only important if you copy (or drag) cells that 

contain formulas. Relative cell references are displayed as a column letter combined with a row number (for 

example: B2, D10, F35). Absolute cell references are displayed with a dollar sign before the column letter and a 

dollar sign before the row number (for example: $B$2, $D$10, $F$35). Let’s consider that we have a simple 

table and we want to include a total showing the amount of money earned that week. The formula will need 

to be the total number of hours worked that week multiplied by the hourly rate. 

Notice that this formula contains a combination of both relative cell references and absolute cell references. 

Once you have entered the formula you can press Enter. The cell should display the number 735 which is the 

total amount of money earned that week. The advantage of using an absolute cell reference to refer to cell “C2” 

means that when you copy (or drag) this formula down to rows 6 and 7 this cell reference will always refer to 

cell “C2”. Drag this formula down to rows 6 and 7 and notice how the relative cell references change 

automatically to refer to the cells in that particular row. 
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Function Function Function Function ---- SUMPRODUCT SUMPRODUCT SUMPRODUCT SUMPRODUCT    
When you are using Excel you often come across a problem that has many solutions. The following is one such 

problem. Which solution you choose is often down to personal preference and related to the features or 

functions you are most familiar with. The problem is how to get the total number of rows that contain text in 

either Column 1 and/or Column 2. A solution that uses the SUMPRODUCT function is probably the simplest 

as all the other solutions require you to enter the formula as an array formula using (Ctrl + Shift + Enter). Out 

of the nine rows in the range “B3:B11”, two of the rows do not contain any data. The correct answer to this 

question is therefore seven. 

The very last formula (in row 21) does not return the correct answer despite the logic being correct. The 

reason this formula returns the number one instead of the number seven has something to do with the use of 

the OR function and is explained in more detailed below. 

Function Function Function Function ----    OROROROR    
You might think the formula above has been entered incorrectly or that the formula does not make sense but 

the real problem seems to be a bit more fundamental. For some reason the OR function is unable to return an 

array of values, even when entered as an array formula. The reason for entering a formula as an array formula 

is because you want the functions and arguments to be treated as arrays and not as individual items. When you 

pass in an array to this function all the arguments are evaluated rather than preserving the array. In this 

example the OR function evaluates all the items in the range and returns 1 which is equivalent to True. 
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Excel 2007 Excel 2007 Excel 2007 Excel 2007 –––– Insert Tab Insert Tab Insert Tab Insert Tab    
This tab contains all the familiar commands from the Insert 

drop-down menu plus a few extra ones. This tab contains five 

groups although the order of these groups seems a little odd. I 

am sure the majority of us are more likely to insert a chart than 

we are to insert an illustration. Maybe this will become clearer 

later on. 

TablTablTablTableseseses    
This group contains two commands. The PivotTable command displays the Create PivotTable dialog box and 

the Table command displays the Create Table dialog box. If you are wondering what the definition of a table 

is, it is the old (Data > List > Create List) command. What was previously called a “List” in 

Excel 2003 is now called a “Table” in Excel 2007. The PivotTable and PivotChart Wizard 

has been replaced with a much simpler dialog box. In fact the PivotTable interface has had 

a complete makeover. In addition to the new Create PivotTable dialog box there is also a 

new PivotTable Options dialog box and enhanced task panes. When a pivot table is active 

you will see two additional tabs displayed at the top of the application. These are displayed under a PivotTable 

Tools heading and provide quick access to all of the pivot table commands. We will be discussing pivot tables 

in much more detail. 

 

Most of the earlier functionality is available using the additional tabs but there are a few features that are not 

accessible. You can still access the old wizard by adding the PivotTable and PivotChart Wizard command to 

your Quick Access Toolbar. 

IllustrationsIllustrationsIllustrationsIllustrations    
The Illustrations group contains four commands and all of these commands 

were previously on the Insert drop-down menu. The Picture command 

displays the familiar (Insert > Picture) dialog box and the Clip Art command 

displays the Clip Art task pane. The Shapes drop-down list gives you easy 

access to all of the built-in AutoShapes. Remember that in Excel 2007 

AutoShapes are just called Shapes. In Excel 2003 these shapes could only be inserted by using the Drawing 

toolbar so having all these shapes consolidated onto a single drop-down list makes inserting shapes a lot easier. 

The SmartArt command displays a dialog box that replaces the earlier Diagram Gallery dialog box. The Radial 

diagram has been added to the Cycle tab and the Venn and Target diagrams have been added to the 

Relationship tab. In addition to the six diagrams previously available there is now a choice from over 100 

different diagrams. We will be discussing SmartArt in much more detail. 

 

When a Shape is active you will see an additional tab displayed under a Drawing Tools heading. This provides 

quick access to all the drawing specific commands such as styles and commands from the Order toolbar and 

Align or Distribute toolbar. When a Picture or an item of Clip Art is active you will see an additional tab 

displayed under a Picture Tools heading. This provides access to all the picture specific commands such as 

styles and sizing options. When a SmartArt object is active you will see two additional tabs displayed under a 

SmartArt Tools heading. These tabs provide quick access to all the relevant commands such as layouts, styles 

and formatting. 
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ChartsChartsChartsCharts    
Most of us will be familiar with charts and how to create 

them and this group gives you quick access to all those 

familiar chart types. The group displays drop-down lists 

for the six most common types of chart. Each drop-down 

list displays a list of the possible subtypes. For example the 

Area drop-down list gives you a choice of either: area, area stacked or 100% area stacked in either 2D or 3D. 

At the bottom of each drop-down list is an option to display the Insert Chart dialog box. This dialog box 

displays all the chart types and subtypes. You can quickly display the Insert Chart dialog box by clicking in the 

bottom right corner of this group. 

HyperlinkHyperlinkHyperlinkHyperlink    
I am not sure if this really needs its own group because all this command does is display the familiar (Insert > 

Hyperlink) dialog box. 

TextTextTextText    
This group is an assortment of useful commands from the Insert drop-down menu. The Text Box command is 

the same as the Text Box command from the Drawing toolbar allowing you to quickly insert and format text 

that is not bound by the cells on the worksheet. The Header 

& Footer command displays your worksheet in the new “Page 

Layout” view. This layout displays your worksheet in a view 

that is similar to the Print Layout view that was available in 

Word 2003. This view lets you quickly add headers and 

footers and adjust the margins on your worksheets. The WordArt drop-down list displays a list of built-in 

WordArt styles that are familiar to the styles available in Office 2003. When a WordArt object is active you 

will see an additional tab under a Drawing Tools heading. This is the same tab that is displayed when a Shape 

is active. 

Insert Tab SummaryInsert Tab SummaryInsert Tab SummaryInsert Tab Summary    
If you asked users for a list of five things they insert when working in Excel and I am confident that three of 

them would be functions, cells and worksheets. None of these can be inserted from the Insert tab despite 

appearing on the Insert drop-down menu in Excel 2003. 

● Insert Function appears on the Formulas tab 

● Insert Cells appears on the Home tab 

● Insert Worksheet appears on the Home tab 

● Insert Comment appears on the Review tab 

How are these “contextHow are these “contextHow are these “contextHow are these “context sensitive” tabs meant to work? sensitive” tabs meant to work? sensitive” tabs meant to work? sensitive” tabs meant to work?    
The more I use the tabs the more confused I am. Sometimes they are context sensitive and sometimes they 

aren’t. For example open Excel and the Home tab is displayed. This tab is always displayed when you first open 

Excel. Select the Insert tab and select the Shapes drop-down list to insert a Rectangle. Drag the Rectangle on to 

your worksheet and the Drawing Tools tab is automatically displayed. Now select cell “B2” and you will notice 

that the Home tab is displayed again. When I click back on the Rectangle for a second time the Drawing Tools 

tab is not automatically displayed. Double clicking on the Rectangle however does automatically display the 

Drawing Tools tab. If anyone can tell me if this is a bug or a feature I would be very much appreciated. The 

same is true for all the tabs although I have yet to find a way to display the PivotTable Tools tab since there is 

no object to double click. 


