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MayMayMayMay 2007  2007  2007  2007 ----    Letter from the EditorLetter from the EditorLetter from the EditorLetter from the Editor    
Welcome to the third edition of the BetterSolutions.com newsletter. After several months of hard work we 

have finally added the additional Knowledge Base pages to the website. An extra page has been added to all the 

Excel, Word and PowerPoint sections to provide you with links to relevant Knowledge Base articles. A lot 

more links will be added next month. There is also a slight change to the graphic at the top and the links on 

the search pages are now underlined. This will make it easier for you to see which keywords have been linked 

and which ones haven’t. We have also created a dedicated Newsletter page to allow visitors easy access to the 

previous issues. The newsletter is proving to be a huge success and we would like to thank all the people that 

have given us feedback. 

Fully IntegratedFully IntegratedFully IntegratedFully Integrated    
Rather than using several different add-ins written and supported by different people we think you would 

prefer to use just one. For the past three years we have been creating some Excel, Word and PowerPoint utility 

add-ins. These add-ins are written entirely with .NET 

technology and bring functionality that has never 

been seen before. In addition to the extra functionality 

these add-ins are fully integrated into the existing 

menus and toolbars to maximise your productivity. 

These add-ins will work seamlessly with Office 2003 

and Office 2007. The screen shot opposite is taken 

from the Excel utility add-in. The Excel add-in is 

being tested extensively at the moment and should be 

ready for beta testing very shortly. The time has come 

to consolidate your add-ins so if you would like us to 

include any specific functionality please let us know. 

support@bettersolutions.comsupport@bettersolutions.comsupport@bettersolutions.comsupport@bettersolutions.com    
This email address is the one you should use when you have any problems or questions with Microsoft Office 

and you want some FREE help and advice. Sending us your questions will not only mean that you get a reply 

immediately but it will also allow us to publish the answers in the next issue, which will help other people as 

well. We spend a lot of time checking and testing the information to ensure that it is accurate but if you do 

spot any mistakes or anything that is wrong then please tell us. We are always looking for ways to improve our 

products and services and always welcome constructive criticism. If you have any comments or suggestions 

regarding this newsletter and its content please tell us. 

How can I unsubscribe to this newsletter?How can I unsubscribe to this newsletter?How can I unsubscribe to this newsletter?How can I unsubscribe to this newsletter?    
All you need to do is send us an email and ask to be removed. Your email address will not be shared or used for 

any other purpose and confidentiality is assured at all times. We were not able to add the unsubscribe link in 

time for this months issue but it will hopefully be added for next month.  
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News and Related InformationNews and Related InformationNews and Related InformationNews and Related Information    

FactFactFactFactssss of the month of the month of the month of the month    
Every issue from now on will include some facts about Excel, Word and PowerPoint that users should be 

reminded about. Our first fact is regarding Excel. Text is automatically left aligned and numbers are 

automatically right aligned when you are using the General number format. This is not a very exciting fact but 

one that we often overlook. To compensate for this rather boring fact here is a more exciting one. In Excel 

when dragging ranges with your mouse, you can hold down the Alt key to drag the range to a different 

worksheet. 

Office 2003 XML file formatsOffice 2003 XML file formatsOffice 2003 XML file formatsOffice 2003 XML file formats    
Using XML as a file format instead of a binary file format significantly reduces the risk of a file containing any 

viruses. Microsoft has just released a utility called Microsoft Office Isolated Conversion Environment 

(MOICE). This allows you to convert Excel, Word and PowerPoint 2003 binary files to their equivalent 2003 

XML file format. This will protect users against any viruses that may exist in the old binary file formats. This is 

only relevant if you are using Office 2003 or Office 2007. If you are using Office 2003 and you want to install 

MOICE you must have the Compatibility Pack for Excel, Word and PowerPoint File Formats installed first. 

Please refer to the following knowledge base article http://suhttp://suhttp://suhttp://support.microsoft.com/kb/93pport.microsoft.com/kb/93pport.microsoft.com/kb/93pport.microsoft.com/kb/935865586558655865 for more details. 

UK Regional DictionariesUK Regional DictionariesUK Regional DictionariesUK Regional Dictionaries    
Microsoft is in the process of creating UK regional dictionaries. These dictionaries will contain common words 

and dialects specific to particular areas in the hope of making Microsoft Office more relevant to the different 

regional voices. If you would like to contribute just send an email to dialect@microsoft.comdialect@microsoft.comdialect@microsoft.comdialect@microsoft.com stating the words 

you would like added and where you live. To find out more about the regional dialect programme you can visit 

the Microsoft website http:/http:/http:/http://www.microsoft.com/uk/dialect/default.mspx/www.microsoft.com/uk/dialect/default.mspx/www.microsoft.com/uk/dialect/default.mspx/www.microsoft.com/uk/dialect/default.mspx. 

Office 2007 and Windows VistaOffice 2007 and Windows VistaOffice 2007 and Windows VistaOffice 2007 and Windows Vista    
If you are using Windows Vista and Office 2007 you might have missed out on some of the security patches 

that were released at the start of the month. The patches that were released have since been updated and 

might have to be installed again. In some cases the automatic detection may not have offered the updates or 

the updates may not have been installed correctly. If you are running Office 2007 and Windows Vista you 

should go ahead and install these updates if they are offered to you. Please refer to the following two 

knowledge base articles http://support.microsoft.com/kb/934233http://support.microsoft.com/kb/934233http://support.microsoft.com/kb/934233http://support.microsoft.com/kb/934233 and http://support.microsoft.com/kb/934873http://support.microsoft.com/kb/934873http://support.microsoft.com/kb/934873http://support.microsoft.com/kb/934873    

for more details. 

DisclaimerDisclaimerDisclaimerDisclaimer    
Better Solutions Limited is in no way associated with Microsoft Corporation. All the content in this newsletter 

and on the website is provided “as is” with absolutely no warranties. We strongly recommend that you back up 

all your data first before installing any updates or third party software. In no event shall Better Solutions 

Limited be liable for any special, indirect or consequential damages whatsoever resulting from loss of use, data 

or profits, whether in an action of contract, negligence or other action arising out of or in connection with any 

information published in this newsletter or on our website. 



May 2007 support@bettersolutions.com 

Copyright © Better solutions Limited. All Rights Reserved. Page 3 of 5 
No part of this publication can be published or reprinted without explicit written permission from Better Solutions Limited 

Your Questions and ProblemsYour Questions and ProblemsYour Questions and ProblemsYour Questions and Problems    
Office Office Office Office ----    Why does Excel beepWhy does Excel beepWhy does Excel beepWhy does Excel beep    when when when when I press certain keysI press certain keysI press certain keysI press certain keys????    
The most likely reason for this is that you accidentally pressed the Alt key when you were editing the cells. 

Excel will beep (or do nothing if you have sound disabled) when you try and access a shortcut key that does 

not exist. Pressing the Alt key automatically activates your menu bar and allows you to select menu items 

using the keyboard rather than the mouse. 

Excel Excel Excel Excel ----    How can I add a shortcut to How can I add a shortcut to How can I add a shortcut to How can I add a shortcut to my my my my desktop in Windows XP?desktop in Windows XP?desktop in Windows XP?desktop in Windows XP?    
1. Right click on the desktop and select (New > Shortcut) from the shortcut menu. This will put a shortcut 

icon on the desktop and will display the Create Shortcut dialog box. 

2. Press the Browse button to select the file you want to associate with the shortcut. Alternatively you can 

type the folder path directly into the textbox. 

3. Press Next and type the name you would like displayed underneath the shortcut icon. 

4. Press Finish to create the necessary shortcut. You can quickly identify shortcuts by their associated icons. 

Shortcuts always contain an arrow in the bottom left corner. 

Excel Excel Excel Excel ----    Why won’t my named range be accepted?Why won’t my named range be accepted?Why won’t my named range be accepted?Why won’t my named range be accepted?    
This is probably because it includes invalid characters. Named ranges cannot start with a number or contain 

any spaces. You also cannot use any names that resemble actual cell addresses (for example: C20, A45, R3C8). 

If you want to include a space, use an underscore instead. 

Excel Excel Excel Excel ----    What isWhat isWhat isWhat is the largest dimension for matrix functions? the largest dimension for matrix functions? the largest dimension for matrix functions? the largest dimension for matrix functions?    
There are four matrix functions provided in Excel and these are MDETERM, MINVERSE, MMULT and 

TRANSPOSE. From the tests that we have done the maximum seems to be about 52 by 52. 

Excel Excel Excel Excel ----    How can I find the number How can I find the number How can I find the number How can I find the number of days between 2 datesof days between 2 datesof days between 2 datesof days between 2 dates????    
There are two functions you can use to achieve this: 

● The total number of days between two dates. Assuming the dates have been typed directly into two cells 

you can just use a formula (=A1-A2) to subtract the earlier date from the later date. Alternatively you could 

use the DATEDIF function. This function does not appear in the Insert Function dialog box nor does it 

display any argument tooltips but it does exist. 

● The total number of days between two dates (excluding weekends). You can use the NETWORKDAYS 

function to automatically exclude Saturday’s and Sunday’s. This function is only available if you have the 

Analysis ToolPak add-in installed. 

● The total number of days between two dates (excluding weekends and bank holidays). You can use the last 

optional argument of the NETWORKDAYS function to include additional dates you want to exclude. 

ExcelExcelExcelExcel    ---- FIND Function? FIND Function? FIND Function? FIND Function?    
One of our users pointed out this month that when you use 

the FIND function in the same row as the first row defined in 

your “within_text” argument you will get the value 1 

returned instead of #VALUE!. That’s a nice feature. 
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Excel 2007 Excel 2007 Excel 2007 Excel 2007 ––––    Tabs, Tabs, TabsTabs, Tabs, TabsTabs, Tabs, TabsTabs, Tabs, Tabs    
Every month we are going to discuss the tabs in more and more detail, trying to highlight all the good, the bad 

and the ugly regarding the new “intuitive” interface. There are seven tabs initially but additional tabs can be 

displayed depending on your personal Excel Options. These tabs will look different depending on how wide 

your Excel application window is. Every tab is divided into “groups” and the name of these groups is displayed 

at the bottom. The screen shot below displays the Home tab in its “narrowest” view. The arrows at the bottom 

of the groups indicate that there is 

not enough space to display these 

commands. Clicking on the large 

group buttons will display the 

commands below. As you make 

your application window wider, 

more and more of the commands 

will be displayed until eventually 

every command from every group is 

visible. Let’s talk a bit more about the Home tab as this is always the default tab when you start Excel 2007. 

The Home tab contains seven groups of commands: 

ClipboardClipboardClipboardClipboard    
This group contains the most important commands of all, namely Cut, Copy, Paste and Paste Special. The 

Format Painter has also been added to this group for quick access. Pressing the arrow below the Paste button 

will display a list of the most common Paste Special options including Paste Values and Paste Link. You can 

quickly display the Clipboard task pane by clicking in the bottom right corner of this group. 

FontFontFontFont    
This group contains a lot of the commands that were previously on the Formatting toolbar including Font, 

Font Size, Font Colour and Increase and Decrease Font. You can quickly 

display the old (Format > Cells) dialog box by clicking in the bottom right 

corner of this group. I am not entirely sure why the Borders command and 

the Fill Colour command have been added but maybe this will become 

clearer later on. 

AlignmentAlignmentAlignmentAlignment    
This group contains all the alignment commands including Top Align, Middle Align and Bottom Align as well 

as a button to quickly apply different orientations to your text. 

Wrapping text in your cells is now a lot quicker with a 

dedicated Wrap Text button. The Merge and Center drop-down 

list is also a nice addition making it very quick to merge and 

unmerge your cells. You can quickly display the (Format > 

Cells)(Alignment tab) by clicking in the bottom right corner of 

this group. 

NumberNumberNumberNumber    
This group contains the familiar number formatting commands from the Formatting toolbar as well as an 

additional Number Format drop-down list. This gives you access to some of the most 

common number formats including Dates and Fractions. You can quickly display the 

(Format > Cells)(Number tab) by clicking in the bottom right corner of this group. 
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StyleStyleStyleStylessss    
This group gives you access to the Conditional Formatting options as well as giving you access to Table Styles 

and Cell Styles. If you make your application window extremely wide you will 

notice that the cell styles button changes to a list box of styles. This could easily 

be mistaken as a list of table styles as there is no tooltip that says cell styles. Both 

table styles and cell styles are new to Excel 2007 and we will be looking at these 

in more detail in subsequent issues.  

CCCCeeeellsllsllslls    
This group contains the commands to let you insert, delete and format cells. This is 

really confusing because the three buttons look similar although they behave 

differently. The Insert and Delete buttons are actually buttons with drop-down lists. 

The buttons do not refer to your last action but instead always refer to “Insert Shifting 

Cells to the Right” and “Delete Shifting Cells to the Left”. The Format button is just a 

drop-down list (no button) and contains commands relating to cell size, visibility, sheet organisation and 

protection. This is a bit confusing as a lot of these commands have nothing to do with cells or formatting. 

EditingEditingEditingEditing    
This group is an assortment of useful commands that previously appeared on the Edit drop-down menu. These 

include the (Edit > Fill) and (Edit > Clear) submenus as well as the Find, Replace 

and Go To commands. I get the feeling that these commands should have been 

integrated into some of the other groups and tabs. In fact the AutoSum does 

appear on the Formulas tab as well. It might have been more intuitive to put the 

Clear drop-down list in the Cells group. 

DeveloDeveloDeveloDeveloperperperper    
If you want to add or edit worksheet controls then you will need to display the Developer tab. This can be 

displayed by selecting (Office Button > Excel Options)(Popular tab, “Show Developer tab in the Ribbon”). I 

would have thought this tab would have contained all the commands relating to macros as well, but three of 

the macro commands are available on the View tab. We will be discussing the Developer tab in much more 

detail. 

AddAddAddAdd----InsInsInsIns    
If you have any third party add-ins installed then these will be displayed on an additional Add-Ins tab. This 

tab will contain any commands that were previously added to menus or toolbars. Two groups will be displayed 

one called “Menu Commands” and one called “Custom Toolbars”. 

Home Tab SummaryHome Tab SummaryHome Tab SummaryHome Tab Summary    
This is the first tab that we have analysed and most of the groups seem to be “intuitive” although I am not so 

sure about the Cells and Editing groups. Here are a few more things we had trouble finding: 

● The Formula Bar is not displayed by default but can be displayed by selecting (Office Button > Excel 

Options)(Advanced tab, “Show formula bar”). There is also a checkbox for this on the View tab in the 

Show/Hide group. 

● There is no command for inserting a function on the Insert tab. You either have to use the shortcut key 

(Shift + F3) or display the Formulas tab to get access to the Insert Function command. 

 

The new tabs will definitely take a bit of time to get used to but the following tip will definitely help. You can 

quickly display a different tab by hovering over the tabs and moving the wheel in the middle of your mouse. 


