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FebruaryFebruaryFebruaryFebruary    2008200820082008    ----    Letter from the EditorLetter from the EditorLetter from the EditorLetter from the Editor    
Welcome to the seventh edition of the BetterSolutions.com newsletter. We have got tonnes of Microsoft 

Office related information to share with you this year and lots of new and exciting developments. In addition 

to sharing our thoughts and tutorials this newsletter will try and explain some of the mysteries behind the 

Microsoft Office applications, especially Office 2003. The most significant development for us this year will be 

the learning and implementation of SharePoint. If you are looking to improve team collaboration or just 

increase productivity on a general level I would suggest having a look at Windows SharePoint Services (WSS). 

At the moment we are doing some preliminary testing but we are hoping to start integrating parts of WSS into 

the website towards the end of the year. 

Office Office Office Office Open XML File FormatsOpen XML File FormatsOpen XML File FormatsOpen XML File Formats    
Often referred to as Office Open XML or just Open XML this is the XML based file format that is used by 

default in Microsoft Office 2007. Office Open XML provides a standardised and open file format that combines 

ZIP data compression with XML. This allows you to quickly access the individual components of an Office 

2007 file by changing the file extension to “.zip”. Office Open XML file formats have been designed to work on 

multiple platforms making it very easy to access and update the information contained in an Office document. 

Open XML is divided into several supporting languages: there is SpreadsheetML for spreadsheets; 

WordprocessingML for documents; 

PresentationML for presentations and 

DrawingML for graphics, charts, tables 

and diagrams. To accompany this new 

file format there is also a new website: 

www.openxmldeveloper.orgwww.openxmldeveloper.orgwww.openxmldeveloper.orgwww.openxmldeveloper.org. This 

website is a dedicated resource for the 

Office Open XML file formats and can 

be used to help answer questions that 

users or developers may have. 

 

It is important to realise that this new Open XML file format is completely different to the Office 2003 XML 

file format. The XML file format available in Office 2003 uses a single XML file with all the content embedded 

inside it as opposed to the open packaging (or zipped) file format used in Office 2007. For older versions of 

Microsoft Office, Compatibility Packs are available from the Microsoft website to provide backwards 

compatibility for the new Open XML file formats. 

support@bettersolutions.comsupport@bettersolutions.comsupport@bettersolutions.comsupport@bettersolutions.com    
This email address is the one you should use when you have any problems or questions with Microsoft Office 

and you want some FREE help and advice. Sending us your questions will not only mean that you get a reply 

immediately but will also allow us to publish the answers in the next issue which will help other people as 

well. We spend a lot of time checking and testing the information to ensure that it is accurate but if you do 

spot any mistakes or anything that is wrong then please tell us. We are always looking for ways to improve our 

products and services and always welcome constructive criticism. If you have any comments or suggestions 

regarding this newsletter and the content contained inside it please tell us. 
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News and Related InformationNews and Related InformationNews and Related InformationNews and Related Information    

Microsoft Office Picture ManagerMicrosoft Office Picture ManagerMicrosoft Office Picture ManagerMicrosoft Office Picture Manager    
Microsoft Office Picture Manager was first introduced with Office 2003 and is a picture editing and 

management application that comes FREE of charge with any installation of Microsoft Office. This application 

replaces Microsoft Photo Editor which was 

available in Office 97, 2000 and 2002. This 

application can be thought of as the big brother to 

Microsoft Paint and is often just referred to as 

Picture Manager. As well as being a file 

management tool it also has better picture quality 

than Microsoft Paint, batch editing, saving and 

renaming, red eye removal and one-click 

compression. It also has the facility to link and 

upload pictures to a Microsoft SharePoint picture 

library making it very easy to share files among 

team members over the Internet. 

 

The application can be accessed from (Start > All 

Programs > Microsoft Office > Microsoft Office 

Tools > Microsoft Office Picture Manager). 

 

We will be adding more information about this 

application in the PowerPoint section of the 

website but for now the best source of information 

is the Office Online website: http://office.microsoft.com/en-gb/help/CH010001171033.aspx 

 

Microsoft Office Isolation Conversion EnvironmentMicrosoft Office Isolation Conversion EnvironmentMicrosoft Office Isolation Conversion EnvironmentMicrosoft Office Isolation Conversion Environment (MOICE) (MOICE) (MOICE) (MOICE)    
This has been mentioned a couple of times before in previous issues but it is such an important aspect of Office 

2007 that we want to try and increase awareness as much as possible. Properly implemented this provides 

users with a way of pre-processing potentially unsafe Office binary files before converting them into Office 

Open XML file format. To install MOICE, you must have either Office 2003 or 2007 installed and have the 

Compatibility Pack for Excel, Word and PowerPoint 2007 File Formats installed. MOICE should be used in 

conjunction with the File Block functionality that is available for Office 2003 and Office 2007. 

File Block FunctionaliFile Block FunctionaliFile Block FunctionaliFile Block Functionalitytytyty    
File Blocking provides a mechanism that can control and block the opening of specific Microsoft Office file 

types. The File Block Functionality for Microsoft Office 2003 and 2007 allows administrators to prevent 

different file types from being opened by using registry settings and group policy. Blocking specific file types 

allows administrators to prevent users from opening certain types of files, such as those most likely to contain 

malicious code. 
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Outlook and Outlook and Outlook and Outlook and Business Contact ManagerBusiness Contact ManagerBusiness Contact ManagerBusiness Contact Manager    
Outlook and Business Contact Manager is a plug-in for Microsoft Outlook that helps you manage all your 

business contacts, accounts, projects, tasks, meetings and email all in one place. This application is Microsoft’s 

equivalent of a CRM (Client Relationship Management) application. You can still keep your personal 

information in Outlook but this provides a central depository for all those business clients and customer 

related information. This application is never installed by default when you install Microsoft Outlook and is 

provided as an additional disk when you purchase one of the following Office 2007 suites: Small Business, 

Office Professional or Office Ultimate. After this has been installed you will need to restart Outlook for the 

installation to complete. All the information is stored in a SQL Server Express database and once installed you 

will see an additional Business Contact Manager drop-down menu as well as a Business Contact Manager 

toolbar. 

 

Fully integrated with Microsoft Outlook it provides you with an additional interface to easily view, edit and 

track your business contacts and sales opportunities. The Business Contacts Dashboard includes quick links to 

the important details of your business allowing you to prioritise more effectively. Quickly view, use and 

update information on your accounts, opportunities and marketing activities in addition to your contact 

information. It can also be closely integrated with Microsoft Office Accounting (previously called Small 

Business Accounting). Any financial data entered in Office Accounting flows directly into Business Contact 

Manager. 

Excel ServicesExcel ServicesExcel ServicesExcel Services    
Excel Services is only available in Office 2007 and is a component of Microsoft Office SharePoint Server 2007. 

This technology allows you to calculate, load and create Excel workbooks remotely from a server. You can 

think of Excel as being the authoring tool and Excel Services as the reporting tool. There are three main 

components: 

Excel Calculation SExcel Calculation SExcel Calculation SExcel Calculation Serviceerviceerviceervice – This is the engine that actually loads, calculates and refreshes the external data 

within the workbooks and also maintains the session state for interactivity. Excel Calculation Services 

maintains a session for the duration of interactions with the same workbook by a user and a session is closed 

when the caller explicitly closes it or when the session times out on the server. Excel Services caches the 

opened workbooks, calculation states, and external data query results, for improved performance when 

multiple users access the same set of workbooks. 

Excel Web ServiceExcel Web ServiceExcel Web ServiceExcel Web Service – This is a web service hosted within SharePoint that gives developers programmatic access 

to its web service. You can develop applications that call Excel Web Services to calculate, set, and extract 

values from workbooks, as well as refresh external data connections. Using Excel Web Services, you can 

incorporate server-side workbook logic into an application, automate the updating of workbooks and create 

application-specific user interfaces around server-side Excel calculations. 

Excel Web AExcel Web AExcel Web AExcel Web Accessccessccessccess – This is a specific web part that displays charts and tables from an Excel workbook in a web 

browser. Although you might be accessing the workbook from within a browser it still looks and feels like 

Excel. Depending on permissions users can then copy the current state of the workbook to their local 

computer for further analysis either as a snapshot or as an Excel workbook. 

DisclaimerDisclaimerDisclaimerDisclaimer    
Better Solutions Limited is in no way associated with Microsoft Corporation. All the content in this newsletter 

and on the website is provided “as is” with absolutely no warranties. We strongly recommend that you back up 

all your data first before installing any updates or third party software. In no event shall Better Solutions 

Limited be liable for any special, indirect or consequential damages whatsoever resulting from loss of use, data 

or profits, whether in an action of contract, negligence or other action arising out of or in connection with any 

information published in this newsletter or on our website. 
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Your Questions and ProblemsYour Questions and ProblemsYour Questions and ProblemsYour Questions and Problems    
 

EEEExcel xcel xcel xcel –––– How can I  How can I  How can I  How can I hide the formulas on my worksheet?hide the formulas on my worksheet?hide the formulas on my worksheet?hide the formulas on my worksheet?    
Hiding your formulas can prevent accidental editing and viewing and can be achieved by protecting the 

worksheet. Before protecting the worksheet you must first specify which formulas you want to hide. By 

default when you protect a worksheet all the formulas in all the cells will be visible. Whether the formulas are 

visible or not is controlled by an option on the (Format > 

Cells) dialog box. Select all the cells that contain the formulas 

you want to hide. You can quickly select formula cells by 

using the (Edit > GoTo) dialog box, pressing the Special button 

at the bottom and choosing “Formulas”. Once the cells are 

selected display the (Format > Cells)(Protection tab) and tick 

the “Hidden” check box. The formulas will only be hidden 

when the worksheet is protected. Select (Tools > Protection > Protect Sheet) and press OK. Adding a password 

is optional. 

 

Excel Excel Excel Excel –––– What is the quickest way to convert dates  What is the quickest way to convert dates  What is the quickest way to convert dates  What is the quickest way to convert dates in thein thein thein the dd.mm.yyyy format? dd.mm.yyyy format? dd.mm.yyyy format? dd.mm.yyyy format?    
The quickest way to change a list of dates in the (01.01.2008) format is to use a formula to change the date into 

its corresponding date serial number. The advantage of expressing a date as a date serial number is that you can 

easily perform addition and subtraction on these dates. If the date you want to convert is in cell “A1” the 

following formula splits the date into its day, month and year components and returns the date as a date serial 

number: 

=DATE(RIGHT(A1,4),MID(A1,4,2),LEFT(A1,2)) 

 

Excel Excel Excel Excel –––– Is there a way to automatically back Is there a way to automatically back Is there a way to automatically back Is there a way to automatically backup my work?up my work?up my work?up my work?    
Yes there is but it is important to emphasis that this is no substitute for pressing the Save button on a regular 

basis. There is an Auto Recover feature in Excel which can provide you with a previously saved copy of your 

workbook. Every time you save a workbook your backup copy will be overwritten. 

In Excel 2003 select (Tools > Options)(Save tab, “Save AutoRecover info every”). 

In Excel 2007 select (Office > Excel Options)(Save tab, “Save AutoRecover info every”). 

In the minutes box type or select the frequency interval. This feature can prove to be extremely useful 

especially if Excel crashes unexpectedly however the automatic saving is quite annoying. 

 

Excel Excel Excel Excel ––––    Why is my name not displayed in the Read Only prompt dialogWhy is my name not displayed in the Read Only prompt dialogWhy is my name not displayed in the Read Only prompt dialogWhy is my name not displayed in the Read Only prompt dialog box box box box????    
Let’s suppose that you work in a small team and your team is responsible for maintaining a large number of 

different workbooks. All the workbooks are saved as read-only and you can normally tell who made the last 

change by looking at the name on the Read Only dialog box. From 

this screen shot you would assume that I was the last person to edit 

this file. This is misleading and is not always accurate. In fact the 

name of the person who last edited the workbook is only updated 

when you save the file using Save As rather than just Save. 

 

Create a workbook and save it with a read-only password. When you next open the workbook you are 

prompted with a read-only prompt and your name will be displayed. Ask one of your colleagues to open the 

workbook, enter the password, make some changes and then save the workbook. Re-open the workbook and 

you will see that it still has your name against it and not your colleagues. The name that is displayed is only 

updated when you use Save As rather than just Save. 
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(Edit > GoTo) dialog box(Edit > GoTo) dialog box(Edit > GoTo) dialog box(Edit > GoTo) dialog box    
This dialog box provides a quick way to move around worksheets and workbooks and can also be used to list 

workbook and worksheet level named ranges. This dialog box will also display the last four cell addresses that 

you jump to, either using this dialog box or using the Name Box. For example select cell “B1” on any 

worksheet and select (Edit > GoTo). Type the cell address “D20” into the reference box and press OK to jump 

straight to that cell. If you select (Edit > GoTo) again you will see that the cell address you were at previously 

has been added to the top of the list (i.e. cell “B1”). Using this technique you can quickly navigate to different 

cells, worksheets and workbooks. This dialog box can be quickly displayed by pressing F5 or (Ctrl + G). 

Here are a few more facts about the (Edit > GoTo) dialog box: 

 

1) An important difference between this dialog box and the (Insert > 

Name > Define) dialog box is that the GoTo dialog box does not show any 

named ranges that contain #REF. This can be very useful when 

debugging large complicated workbooks. 

2) The Reference box can only be used to type in cell addresses or named 

ranges. If you want to select anything else then you must press the 

Special button. 

3) There is no way to delete the four most recently used cell addresses 

without closing the workbook(s) and reopening them. These cell 

addresses are workbook dependent and will be available all the time that 

particular workbook remains open. 

4) The four recently used cell addresses will always be displayed as a cell reference relative to the active 

workbook. If you are using this technique to move between different workbooks then the cell reference will 

look different depending on which workbook is active when the dialog box is displayed. 

 

Paste Special Dialog BoxPaste Special Dialog BoxPaste Special Dialog BoxPaste Special Dialog Box    
When you copy data between cells, worksheets and workbooks in the same session of Excel the Paste Special 

dialog box will always be the dialog box on the left. This contains the very useful options like Values, Column 

Widths, Skip Blanks, Transpose and Paste Link. If the data has been copied from a different Excel session or 

from a different application altogether and you display the Paste Special dialog box you will get the dialog box 

on the right. 
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Excel 2007 Excel 2007 Excel 2007 Excel 2007 ––––    DataDataDataData Tab Tab Tab Tab    
This tab probably looks the most unfamiliar out of all of them but don’t be put off. The majority of these 

commands are available in Excel 2003 although some of them were not easily accessible. There are several 

additional commands but the most significant changes have been to the Get External Data group. Spreadsheets 

are increasingly used to present data from 

other systems: either databases, web 

services or just flat files and being able to 

control and update this information 

quickly is becoming more important. In 

Excel 2003 data could be connected to a 

workbook in two ways either storing the 

connection information in the workbook 

itself as a “workbook connection” or by using a “connection file” typically an Office Data Connection (ODC) 

file. Connection files just provide an easy way to share and reuse connections to the same data sources without 

having to enter all the connection details again. The only real change in Excel 2007 is that this functionality is 

now a lot more accessible and that all the data connections can be managed from a single dialog box. 

 

Get External DataGet External DataGet External DataGet External Data    
The “From Access” button gives you a quick way to insert data 

from an Access database. This displays the Select Data Source 

dialog box which is the old (Data > Import External Data > 

Import Data) dialog box with the filter changed to files of type 

“Access Databases”. The “From Web” button displays the New 

Web Query dialog box and replaces the old (Data > Import External Data > New Web Query). The “From 

Text” button displays the Import Text File dialog box which is the old (Data > Import External Data > Import 

Data) dialog box with the filter changed to files of type “Text Files”. 

 

The “From Other Sources” drop-down list provides you with a list of other common data sources which you 

might want to retrieve data from including: SQL Server database, Analysis Services, XML Data Source, Data 

Connection Wizard and Microsoft Query. The SQL Server, Analysis Services and Data Connection Wizard all 

display the Data Connection Wizard which is the old (Data > Import External Data > Import Data)(New 

Source) dialog box. The XML Data Source is the old (Data > XML > Import) dialog box and the Microsoft 

Query is the old (Data > Import External Data > New Database Query) dialog box. The most significant change 

is the new Existing Connections dialog box. This dialog box lets you find existing connection files on your 

computer and on your network. 

 

ConnectionsConnectionsConnectionsConnections    
The “Refresh All” button and drop-down list display commands from the earlier 

External Tools toolbar and include the Refresh All, Refresh, Refresh Status, Cancel 

Refresh and Connection Properties commands. The “Connections” button displays 

the new Workbook Connections dialog box which helps you to manage all the 

connections that are used within a workbook. This dialog box not only shows you 

where every connection is used but also displays a large number of useful properties including automatic 

refresh options as well as the full connection string. The “Properties” button displays the External Data 

Properties dialog box that just contains some of the options from the previous Data Range Properties dialog 

box. The “Edit Links” is the old (Edit > Links) command which displays a list of any external references used in 

a workbook. 
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Sort & FilterSort & FilterSort & FilterSort & Filter    
The “Sort Ascending” and “Sort Descending” buttons are just the equivalent 

buttons from the Standard toolbar. The “Sort” button displays a new Sort 

dialog box making it very easy to sort your data. This dialog box includes 

several new options. The most noticeable are that you can now sort by any 

number of columns rather than being restricted to just three and being able 

to sort by colour. The “Filter” button provides a very quick toggle to the old (Data > Filter > AutoFilter) 

command. The “Clear” button quickly removes any filtering criteria from the current range or table. This is 

the equivalent to selecting (All) in every column. The new “Reapply” button is extremely confusing at first and 

only makes sense when you have a filter (and/or sort) applied to a table and you then add “more” data. This 

will reapply the current sort and filter criteria to make sure the additional rows are also sorted and filtered 

accordingly. The “Advanced” button provides access to the old (Data > Filter > Advanced) dialog box. 

 

Data ToolsData ToolsData ToolsData Tools    
The “Text to Columns” button is the old (Data > Text to 

Columns) dialog box. The “Remove Duplicates” button is 

an addition and is very handy when you want to quickly 

remove those annoying duplicates from list or table. The 

“Data Validation” button is the old (Data > Validation) 

dialog box and the drop-down gives you quick access to the Circle Invalid Data and Clear Validation Circles 

commands from the previous Formula Auditing toolbar. The “Consolidate” button is the old (Data > 

Consolidate) dialog box. The “What-If Analysis” drop-down displays three commands: Scenario Manager, Goal 

Seek and Data Table. The Scenario Manager is the old (Tools > Scenarios) command, The Goal Seek is the old 

(Tools > Goal Seek) command and Data Table is the old (Data > Table) command. 

 

OutlineOutlineOutlineOutline    
This group contains all the buttons and commands from the old 

Group and Outline extension menu and the functionality has not 

changed. The “Group” button and drop-down list contains the Group 

command and the Auto Outline command. The button always 

provides access to the Group command. The “Ungroup” button and 

drop-down list contains the Ungroup command and the Clear Outline command. The button always provides 

access to the Ungroup command. The “Subtotal” button (no drop-down list) is the old (Data > Subtotals) 

command. The “Show Detail” and “Hide Details” commands are the same as those on the old Group and 

Outline extension menu. Clicking in the bottom right corner of this group will display the old (Data > Group 

and Outline)(Settings) dialog box. 

 

Data AnalysisData AnalysisData AnalysisData Analysis    
This provides access to the previous Analysis ToolPak add-in and will only appear when 

this add-in is loaded. This was previously accessible from the (Tools > Data Analysis) 

command. Although this add-in is not loaded by default you no longer have to worry about 

the extra worksheet functions as all these functions are now available by default. 

 

Data Tab SummaryData Tab SummaryData Tab SummaryData Tab Summary    
This tab is well organised and despite looking a bit scary initially there is not a great deal of new functionality. 

The improved Sort dialog box is a great addition as is the new Remove Duplicates functionality. The improved 

connection dialog boxes are very useful and making the Analysis ToolPak functions part of the default 

installation makes things a lot simpler. 


