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MayMayMayMay    2008200820082008    ----    Letter from the EditorLetter from the EditorLetter from the EditorLetter from the Editor    
Welcome to the eighth edition of the BetterSolutions.com newsletter. There are plenty of books and blogs 

covering all the basic Microsoft Office functionality so in this newsletter we will be discussing some of the less 

talked about topics. It is very difficult to know exactly what level to pitch the content so if you feel the articles 

are a bit too advanced, then please let us know. We have got some interesting topics for you in this issue 

including an article on the Research Task Pane. We have also started to expand the website to include Outlook 

as well although it will be a long time before any of this content gets uploaded. With more and more users 

turning to Office 2007, the demand for professional Microsoft Office consultancy will only increase. The 

combination of .NET, SharePoint and Office 2007 has the potential to significantly increase productivity and 

we are determined to help you, not only with the transition but also to provide you with the solutions and the 

support you need. 

Office 2007 MigrationOffice 2007 MigrationOffice 2007 MigrationOffice 2007 Migration    
For a lot of companies this migration will be slow but for us this migration has already started. Over the 

coming months you will start to notice the website screen shots being replaced with Office 2007 screen shots 

as well as more of the blank pages being populated with content. Although most of the core functionality has 

not changed the ribbon definitely makes the large number of commands more accessible and easier to find. 

Pressing the Alt key displays the shortcut keys for all the tabs and the Quick Access toolbar. Once a particular 

letter has been pressed the shortcut keys for all the groups and commands on that tab are displayed. This 

allows you to quickly identify each command. 

Excel Utility AddExcel Utility AddExcel Utility AddExcel Utility Add----inininin    
The development of our Excel utility add-in has been put on hold for the time being as all our resources are 

focused on Office 2007 and SharePoint integration. This general utility add-in when released will be the first 

add-in of its kind to be written entirely with .NET technology. Not only that but it will also be the first add-in 

that is truly integrated into Excel. If you would like to find out more or be involved with our beta testing, 

please get in touch. 

support@bettersolutions.comsupport@bettersolutions.comsupport@bettersolutions.comsupport@bettersolutions.com    
This email address is the one you should use when you have any problems or questions with Microsoft Office 

and you want some FREE help and advice. Sending us your questions will not only mean that you get a reply 

quickly but will also allow us to publish the answers in the next issue which will help other people as well. We 

spend a lot of time checking and testing the information to ensure that it is accurate but if you do spot any 

mistakes or anything that is wrong then please tell us. We are always looking for ways to improve our 

products and services and always welcome constructive criticism. 
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News and Related InformationNews and Related InformationNews and Related InformationNews and Related Information    

Visual Studio Tools for Applications (VSTA)Visual Studio Tools for Applications (VSTA)Visual Studio Tools for Applications (VSTA)Visual Studio Tools for Applications (VSTA)    
VBA is the programming language behind the Microsoft Office applications and is currently being upgraded to 

bring it inline with .NET. This enhanced application will become part of the Visual Studio family and will be 

called Visual Studio Tools for Applications (VSTA). This development environment will provide a .NET 

platform for customising Microsoft Office applications and will almost certainly sit alongside Visual Basic for 

Applications (VBA) in the next version of Microsoft Office. VSTA will support both the Visual Basic and C# 

programming languages and will simplify the loading and unloading of add-ins into separate application 

domains. In Office 2007 the only application that has the new VSTA environment is InfoPath. 

 

The most significant change is that any solution written in VSTA will be fully compatible with Visual Studio. 

This will enable professional developers to maintain and support applications that have been created by users 

on their desktops. In the last four versions of Microsoft Office macros have been easily accessible to all users 

giving them the ability to create complicated and sometimes unsupportable solutions. Although this has given 

the users an enormous amount of control it has often been frustrating for the IT departments. The removal of 

the macro recorder in PowerPoint 2007 is an indication that Microsoft thinks writing code is more a task for 

developers rather than end users. The macro recorder is still available in Excel and Word 2007. 

Windows Windows Windows Windows SharePointSharePointSharePointSharePoint Services (WSS) Services (WSS) Services (WSS) Services (WSS)    
The term SharePoint does not actually refer to any one particular application but more of an umbrella term 

that includes several products. For most people though when they talk about SharePoint they are referring to 

Windows SharePoint Services. WSS is a web based, team collaboration tool that is designed to increase 

productivity when using Microsoft Office. This product has been designed specifically to help teams share 

information and includes document libraries, workflow, knowledge bases, discussion boards, dashboards, 

announcements, team calendars and much more. You might also have heard people talking about MOSS or 

Microsoft Office SharePoint Server. MOSS can be thought of as the big brother to WSS and includes more 

enterprise functionality. 

 

It is interesting to think that although Excel is the application that gets the most publicity it is really Outlook 

that should have all the lime light. If you were to ask users what is the first application they open in the 

morning, 99% of people would say Microsoft Outlook. Outlook has not only become the most important 

application on the desktop but managing emails is the most important task of the day. The typical workplace 

has an endless flow of emails and attachments and for most of us, sending as many emails as possible to as 

many people as possible is a way of symbolising how valuable we are. Whatever happened to that quick phone 

call or even popping round to the other person’s desk? SharePoint provides a single workspace for teams to 

share information, coordinate schedules, organise documents, and participate in discussions both within the 

organisation and over the Internet. We believe SharePoint will go a long way to not only simplifying the 

workplace but also in reducing the number of unnecessary emails and attachments. For those of you interested 

in being more productive you can download a free trial of WSS from the Microsoft website. There are also lots 

of websites offering hosted WSS sites, most of them offering 30 day trials. 
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Your Questions and ProblemsYour Questions and ProblemsYour Questions and ProblemsYour Questions and Problems    
 

Excel Excel Excel Excel –––– Why Why Why Why do do do does my formula returnes my formula returnes my formula returnes my formula return #N #N #N #NAME?AME?AME?AME?    
There are lots of different errors that you can get when editing and updating formulas and #NAME? is one of 

them. The following is a list of the reasons why a formula might return a #NAME? error: 

● Using an Analysis ToolPak function when the Analysis ToolPak add-in is not installed. 

● Using a worksheet function that does not exist or has been spelt incorrectly. 

● Referring to a named range that does not exist. 

● Using an invalid cell reference. 

● Referring to a worksheet that does not exist. 

● Using text labels when labels are not allowed. 

● Entering text that is not enclosed in speech marks. 

● Entering values that start or contain unrecognised characters. 

 

Excel Excel Excel Excel ––––    Is there an easy way to find missing parentheses in formulas?Is there an easy way to find missing parentheses in formulas?Is there an easy way to find missing parentheses in formulas?Is there an easy way to find missing parentheses in formulas?    
If you enter a formula which has missing (or spare) parentheses at the end you will be prompted with the 

following message. Pressing yes will insert or remove the necessary parentheses from the end of the formula. 

 

 

 

 

 

 

 

Most of the time though it will not be that easy and you will be prompted with a slightly different message 

either “Your formula is missing a parenthesis”, “The formula you typed contains an error” or “You’ve entered 

too many arguments for this function”. 

 

If your formula is really long and contains several sets of parentheses, it can sometimes be difficult to identify 

which one is missing. The most effective way is to use the formula bar and use the arrow keys to move the 

cursor through the formula one character at a time. If your formula contains embedded parentheses then the 

opening and closing parentheses will be displayed in different colours. When the cursor moves over a 

parenthesis, the opening and closing parentheses are highlighted so they can be easily identified. The Evaluate 

Formula dialog box can also be used to help identify the different parts of a nested formula. 

 

Excel Excel Excel Excel –––– How can I transpose cells that contain form How can I transpose cells that contain form How can I transpose cells that contain form How can I transpose cells that contain formulas?ulas?ulas?ulas?    
If you have cells that contain formulas and want to transpose those cells without changing the cell references 

you can quickly replace the “=” with a different character, for example “@”, transpose the cells and then 

replace all the “@” characters with “=”. This will leave your relative references intact. 

DisclaimerDisclaimerDisclaimerDisclaimer    
Better Solutions Limited is in no way associated with Microsoft Corporation. All the content in this newsletter 

and on the website is provided “as is” with absolutely no warranties. We strongly recommend that you back up 

all your data first before installing any updates or third party software. In no event shall Better Solutions 

Limited be liable for any special, indirect or consequential damages whatsoever resulting from loss of use, data 

or profits, whether in an action of contract, negligence or other action arising out of or in connection with any 

information published in this newsletter or on our website. 



May 2008 support@bettersolutions.com 

Copyright © Better solutions Limited. All Rights Reserved. Page 4 of 8 
No part of this publication can be published or reprinted without explicit written permission from Better Solutions Limited 

Calculation Calculation Calculation Calculation –––– Manual or Automatic Manual or Automatic Manual or Automatic Manual or Automatic    
Regardless of whether you are a beginner or an advanced user it is important to understand how calculation 

works and how you can control it. This setting can be found on the (Tools > Options)(Calculation tab) and 

although it might look like an “application level” setting it is in fact more like a “workbook level” setting. If 

you change your setting to manual and close Excel there is no guarantee that when you next open Excel your 

calculation will be set to 

manual. Also if you change the 

calculation to automatic in a 

specific workbook and save the 

changes there is no guarantee 

that the next time you open that workbook that the calculation will be set to automatic. This is extremely 

confusing for most users and causes a lot of frustration. It is important to remember that changing the 

calculation setting in one workbook also changes the setting for that whole instance of Excel. 

Why does my calculation setting keep changing?Why does my calculation setting keep changing?Why does my calculation setting keep changing?Why does my calculation setting keep changing?    
There are a couple of things that can affect this setting. The first and probably the most important is how a 

workbook is opened. Is the workbook opened in an existing instance of Excel or does an instance of Excel need 

to be opened at the same time you open the workbook (for example when you double click an Excel file in 

Windows Explorer)? When you open an instance of Excel (on its own) the calculation setting is determined by 

the first workbook that is opened. It doesn’t matter what settings have been saved in your individual 

workbooks, the setting for that instance is determined by the setting that is saved in the first workbook that is 

opened. For most of us when we open Excel a blank workbook is automatically opened for us. This blank 

workbook is extremely important as it will contain your default calculation setting. This is automatic by 

default however you can easily overwrite this setting if you want to change your default calculation to manual. 

To change your default setting to manual, create an Excel template called Book.xlt, change the calculation to 

manual and save it in your XLSTART directory. 

 

You can also open a workbook by double clicking on an Excel file in Windows Explorer or opening it from an 

email attachment. If you have any instances of Excel already open this workbook will be opened in the 

instance that was last active. In this situation the calculation setting saved in that particular workbook is 

ignored since the default setting has already been set. However if Excel is not already open and you double 

click on a workbook (or open it from an attachment) this workbook will be the first workbook that is opened 

and therefore Excel will default to whatever calculation setting is saved in that workbook. It is impossible to 

know what calculation setting has been saved in a workbook before it is opened especially if you are opening 

workbooks that have been created by other people. There is no simple solution to this problem. 

 

The third reason might be because you are opening workbooks (or add-ins) that contain VBA macros and the 

macros are changing your setting behind the scenes. It is very common for developers to switch the calculation 

to manual while manipulating data on a workbook and then forgetting to reset it once the macro has finished. 

It is possible to change the calculation setting when you open a workbook by using a few lines of VBA code:  
Private Sub Workbook_Open() 

   Application.Calculation = xlCalculation.xlCalculationAutomatic 

End Sub 

This approach works fine when you default calculation is set to manual and you want to switch to automatic. 

However this approach doesn’t work when your default is set to automatic and you want to switch to manual. 

When your calculation is set to automatic Excel automatically recalculates every workbook as soon as it is 

opened and unfortunately the Workbook_Open event is fired after this. 
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Office 2007 Office 2007 Office 2007 Office 2007 Ribbon RecapRibbon RecapRibbon RecapRibbon Recap    
Ribbon Ribbon Ribbon Ribbon ––––    As you know the ribbon has replaced the toolbars and menus and is not customisable. You can 

quickly hide (or display) the ribbon at any time just by double clicking on the active tab. 

Quick Access Toolbar Quick Access Toolbar Quick Access Toolbar Quick Access Toolbar ––––    This is the toolbar that appears at the top of your application and is the only part of 

the interface that is customisable. By default this toolbar displays the Save, Undo and Redo commands. 

OfficeOfficeOfficeOffice Button Button Button Button – This is the large circular button in the top left corner of the application. This contains all the 

features that are used to create and manage files and was discussed in detail in the November 2007 issue. This 

is also the place where you can access your application options (previously (Tools > Options)). 

TabTabTabTab – The ribbon is divided into seven tabs and each tab contains the commands relating to a particular task. 

For example the Formulas tab contains all the commands that relate to working with formulas and functions. 

GroupGroupGroupGroup – Each tab is further divided into groups that relate to specific items of functionality. For example the 

Alignment group on the Home tab contains all the commands that relate to cell alignment and positioning. 

CommandsCommandsCommandsCommands    – These are the individual controls found inside a group. These include buttons, checkboxes, 

combo boxes, drop-down boxes, edit boxes, galleries and toggle buttons. 

Dialog Box LauncherDialog Box LauncherDialog Box LauncherDialog Box Launcher – This is the small arrow symbol that sometimes appears in the bottom right corner of a 

group. Clicking this will display a dialog box or task pane that displays options relating to this specific 

command. Most of the dialog boxes are exactly the same as those in Excel 2003.  

Contextual TContextual TContextual TContextual Tabsabsabsabs – These are tabs that only appear when a specific object is selected. This is to try and keep the 

screen uncluttered and only display the commands relevant to the current task. The three additional tabs 

under the heading Chart Tools show the contextual tabs when a chart is selected. 

Command Tip BoxCommand Tip BoxCommand Tip BoxCommand Tip Box – When you hover over any ribbon commands a large tip is displayed giving you more 

information on that command plus any corresponding shortcut key. 

Mini ToolbarMini ToolbarMini ToolbarMini Toolbar – This is the toolbar that is displayed just above the cursor when you press the opposite button 

on your mouse. This provides you with quick access to all those useful formatting commands without having 

to drag the mouse all the way to the top of the screen. This is in addition to the shortcut menu that also 

appears. This is a great addition but if you find this annoying it can be switched off from your (Office > Excel 

Options)(Popular tab).  

Shortcut MenuShortcut MenuShortcut MenuShortcut Menu – These are the shortcut menus which are exactly the same as those in Excel 2003. 
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Function Function Function Function –––– AVERAGEIF AVERAGEIF AVERAGEIF AVERAGEIF    
This function is only available in Excel 2007 but before we look at this new function lets just remind ourselves 

of the different formulas that could be used in Excel 2003 to calculate averages. The AVERAGE function will 

return the average value from a range of cells and will ignore both blank cells and cells which contain text. 

There is a problem with this function though, it will include cells that contain zero values. Including zero 

values can sometimes be misleading as the average will be lower than expected. If you don’t want to include 

zero values then there are a few alternatives. 

 

You can either use a combination of the SUM, COUNT and COUNTIF functions or a combination of the SUM, 

SUMPRODUCT and ISNUMBER functions. Both of these combinations will ignore blank cells, cells that 

contain text and cells which contain zero values. There are two more alternatives that include using the 

database function DAVERAGE or by using an array formula in conjunction with the AVERAGE and IF 

functions. Obviously using an array formula is the most complicated and also the most inefficient although 

there are scenarios when this is the only option. When you want to return the average based on multiple 

criteria this can only be achieved using an array formula. 

 
The new AVERAGEIF function simplifies all of this giving you an average function that behaves in an 

identical way to the COUNTIF and SUMIF functions. This new function makes it very easy to find the average 

value based on a given criteria and removes the need to use an array formula. 

Function Function Function Function ---- IFERROR IFERROR IFERROR IFERROR    
This function is only available in Excel 2007 and lets you specify what value to return when a formula (or 

expression) evaluates to an error. This new function can be used to reduce the length of complicated formulas 

because there is no need to enter the expressions twice, once to check for an error and then again to generate 

the result if an error does not exist. One of the most common places where errors need to be trapped and 

handled is when using VLOOKUP functions. 
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Research Task PaneResearch Task PaneResearch Task PaneResearch Task Pane 
There is very little information available about the Research Task Pane so here is a quick overview. This task 

pane was introduced in Office 2003 and is available in Excel, Word and PowerPoint. It lets you search local 

and remote data sources without having to leave the application and displays information from a wide range of 

different services. Some are free and some require subscription. A few of these are especially useful such as the 

dictionary and thesaurus. When you first open the task pane it will default to the All Reference Books search 

category. When you want to search for something you can either select an entire search category or an 

individual resource below each category. This task pane will store your last 10 searches. The exact list of 

categories and resources will depend on your location and whether you are working online or offline. There 

are three search categories: 

 

All Reference BooksAll Reference BooksAll Reference BooksAll Reference Books    
The Dictionary lets you look up words or phrases in the Encarta 

dictionary. This contains over 400,000 entries and in addition to 

definitions, includes pronunciation keys, word histories, and word 

usage notes. The Thesaurus lets you look up synonyms while you 

work and insert them into your file directly. You can also click a result 

to look up additional words. The Translation lets you get translations 

quickly using bilingual dictionaries to translate single words or short 

phrases. If you want to search both the dictionary and the thesaurus at 

the same time, select the entire category. When you are working 

offline the dictionary and thesaurus features will use the functionality 

installed with the application. 

 

All Research SitesAll Research SitesAll Research SitesAll Research Sites    
The Encyclopaedia lets you research your subject using the Encarta 

Encyclopaedia. This contains more than 42,000 articles allowing you 

to review the results or ask questions. Factiva iWorks and HighBeam 

Research both offer a collection of business content from a wide 

number of different sources. These sources include articles from newspapers (such as the Financial Times), 

magazines (such as The Economist) and newswires (such as Reuters). Both these services are subscription 

based. Information that is not free to access is indicated by a small money icon. The last category here is MSN 

Search which is exactly the same as using MSN Search from a browser. Clicking on one of these links will open 

up the necessary page in a browser. If you are using Internet Explorer then your task pane will also be 

displayed in your browser. If you are searching multiple categories then the results will be grouped by the 

different resources. 

 

All Business and Financial SitesAll Business and Financial SitesAll Business and Financial SitesAll Business and Financial Sites    
MSN Money Stock Quotes lets you look up stock quotes and company information directly within Excel and 

lets you search using stock symbols and company names. This is a great feature although from our experience 

it is not very easy to use. The Thomson Gale Company Profiles lets you retrieve basic facts about companies 

such as company address, number of employees, website address etc. Not all languages support this particular 

search category. We will be discussing MSN Money Stock Quotes in more detail. 

 

If your company has an intranet site, you can also add it to the Research Task Pane for easy access. Microsoft 

Office SharePoint sites are supported. To add a SharePoint site to the list of All Research Sites you can add the 

URL using the Add Services dialog box. 
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Excel 2007 Excel 2007 Excel 2007 Excel 2007 –––– Review Tab Review Tab Review Tab Review Tab    
This tab contains all the controls relating to Spelling & Grammar, Comments, Track Changes and Protection. A 

lot of these commands were hard to find in Excel 2003 but are now 

very easily accessible. These commands have been taken from the 

Tools drop-down menu, the Reviewing toolbar and the Protection 

toolbar. This tab also exists in both Word and PowerPoint 

although the specific commands do vary. None of this functionality 

has changed in Office 2007. Having this tab in all the applications 

definitely makes it a lot easier to compare functionality. 

 

ProofingProofingProofingProofing    
Three of these commands use functionality built-in to the Research Task Pane. The “Spelling” button is the old 

(Tools > Spelling) command and displays the Spelling dialog box. The 

“Research” button is the old (Tools > Research) command. This displays 

the Research Task Pane and also provides a quick toggle for showing or 

hiding this task pane. The “Thesaurus” button is the old (Tools > 

Research) command and displays the Research Task Pane with Thesaurus 

selected in the drop-down box. This allows you to look up different words with the same meaning (synonyms) 

or words with the opposite meaning (antonyms). The “Translate” button displays the Research Task Pane with 

Translation selected in the drop-down box. This gives you quick access to over 14 languages and lets you 

quickly translate single words or short phrases from one language to another. To translate a specific word, 

press Alt and click on the word. To translate a short phrase, hold down the Alt key and click on the selection. 

 

CommentsCommentsCommentsComments    
Adding comments to your cells especially those that 

require data input or contain formula is extremely 

useful. All of these commands have been taken directly 

from the Reviewing toolbar. The “New Comment” 

button inserts a comment into the active cell and has 

been taken directly from the Cell shortcut menu. This button automatically changes to “Edit Comment” when 

you select a cell that already contains a comment. The “Delete Comment” button removes the comment from 

the active cell. The “Previous Comment” button goes to the previous comment in the active workbook. The 

“Next Comment” button moves to the next comment in the active workbook. The “Show / Hide Comment” 

button displays or hides the comment in the active cell. The “Show All Comments” button displays all the 

comments in the active workbook. The “Show Ink” button can be used to toggle the display of ink added with 

a tablet PC. 

 

ChangesChangesChangesChanges    
This group contains buttons that have been taken 

from the (Tools > Protection) sub menu and the 

Protection toolbar. The “Protect Sheet” button is the 

old (Tools > Protection > Protect Sheet) command. 

The “Protect Workbook” button is the old (Tools > 

Protection > Protect Workbook) command. The “Share Workbook” button is the old (Tools > Share 

Workbook) command. The “Protect and Share Workbook” button and the “Allow users to Edit Range” button 

are also from the (Tools > Protection) sub menu. The “Track Changes” drop-down list gives you access to the 

Highlight Changes and Accept Reject Changes commands. 


